mojo 라이브러리를 받아서 설치하는 과정에 경고가 발생함.


$ perl Makefile.PL

Warning: prerequisite IO::Socket::IP 0.37 not found.

Writing Makefile for Mojolicious

Writing MYMETA.yml and MYMETA.json


MAC에서 수행, 내 PC에 내가 admin이므로 관리자 권한으로 설치함.

모듈을 못 찾으니 찾을 수 있도록 그 모듈을 설치함.

$ sudo perl -MCPAN -e shell


cpan[1]> install IO::Socket::IP

Reading '/Users/jeonbyeong-u/.cpan/Metadata'

  Database was generated on Thu, 28 Jan 2016 19:29:02 GMT

Running install for module 'IO::Socket::IP'

... 중략 ...

Running Build test

t/00use.t ........................... ok

t/01local-client-v4.t ............... ok

t/02local-server-v4.t ............... ok


$ perl Makefile.PL

Writing Makefile for Mojolicious    <-- 모듈 설치 후에 경고 사라짐

Writing MYMETA.yml and MYMETA.json

'Language > PERL' 카테고리의 다른 글

모듈이 없는 경우  (0) 2016.01.29
PERL 아파치 로그 정규식 라이브러리  (0) 2016.01.27
PERL 확장자 *.pm *.pl 차이  (0) 2016.01.27
Perl 네트웍 (링크)  (0) 2012.08.28

+ Recent posts